.NET Framework

The LT-55 XL software requires Microsoft’s .NET Framework version 2.0, 3.5 and 4.0 to be installed on your Windows PC in order for it to be installed and run. Most computers that have been built in the past 2-3 years will already have 2.0 and 3.5 installed but some older ones might have a previous version installed or none at all. Only computers purcahsed in the last year will have 4.0 installed from the manufacturer. If you need to install one or all of the .NET Frameworks, please click the link below to download it and then install it.

Microsoft .NET Framework 2.0 (x86)
Microsoft .NET Framework 2.0 (x64)
Microsoft .NET Framework 3.5 SP1 (x86)
Microsoft .NET Framework 4.0 (x86/x64)

No Comments

Sorry, the comment form is closed at this time.